Back to overview
Downtime
Hardware Failure
Apr 30 at 08:00am GMT-5
Affected services
NGINX
WEBIN CLOUD SERVICES
RYZHELL CLOUD SERVICES
ITZGALAXY MINECRAFT NETWORK
Resolved
May 01 at 07:00pm GMT-5
We had some problems with the server hardware, all services should be online again.
Affected services
Created
Apr 30 at 08:00am GMT-5
Brookz server stopped suddenly.
Affected services