Back to overview
Resolved
ItzGalaxy Website Issues
Apr 5, 2025 at 12:03am UTC
Affected services
WEBSITE
NGINX
Resolved
Apr 7, 2025 at 9:24pm UTC
All services are back online
Affected services
Created
Apr 5, 2025 at 12:03am UTC
We have knowledge about the issue and we are currently working to fix it.
Affected services